[NRVR-Members] Stratologger CF

Weeks, Thomas t.weeks at vt.edu
Fri Apr 5 15:12:31 CDT 2019

I have a SL and DT4U cable too if you need one (I think). I've never used it though.. but with any FTDI device, Linux doesn't normally need drivers, it just works (same serial chip that some arduinos use).

One possible suggestion.. If you have to manually set the serial com port settings in Windows, try turning off hardware and/or software flow control. That's a common glitch with most serial interconnects.


From: nrvr-members-bounces at server2.nrvr.org <nrvr-members-bounces at server2.nrvr.org> on behalf of Pat Artis <pat.artis at gmail.com>
Sent: Friday, April 5, 2019 3:24 PM
To: NRV Rocketry Members
Subject: Re: [NRVR-Members] Stratologger CF


NASA SLI requires stratologger altimeters. My team is in Huntsville now for competition but we will be back Sunday. You can get with them next week.

Pat Artis

Sent from my iPhone

On Apr 5, 2019, at 1:54 PM, Adrien Drouault <adrien.drouault at gmail.com<mailto:adrien.drouault at gmail.com>> wrote:

Anyone have any experience with one of these, and specifically with the DT4U USB interface?

(Yes, I already e-mailed Stratologger support, but it's been a few weeks and I haven't gotten a response, yet, so I'm hoping to leverage our combined electronics knowledge).

I've downloaded the latest FTDI drivers, and have the latest version of PerfectFlite DataCap that's available on the website.

Windows sees the USB serial port, and settings are as specified in the manual (9600, 8-N-1).

The StratoLogger goes through its normal beeps at startup.  During the beeping, I select "acquire" in DataCap, and then, shortly, I get a message box with "DiagCode: 02, 0".  After pressing "OK" to that, I get the "no altimeter found" dialog.  (The only references I've been able to find to this error message state that it comes if you wait "too long", after the beeping finishes, to select acquire).

I know the altimeter works, because it flew on my L2 flight at the last launch, and worked perfectly.

I've tried a couple of different (known-good) USB cables, no difference.  About the only things I haven't tried are a different DT4U, and different computer.  I do still have a Win 7 machine around; maybe it doesn't like Win 10.  For that matter, has anyone tried running DataCap under WINE?

Stumped and open to suggestions


Quidquid latine dictum sit, altum viditur.
NRVR-Members mailing list
NRVR-Members at mail.nrvr.org<mailto:NRVR-Members at mail.nrvr.org>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://server2.nrvr.org/pipermail/nrvr-members/attachments/20190405/7436ddec/attachment-0001.html 

More information about the NRVR-Members mailing list